page contents

fastjson < 1.2.61 反序列化远程代码执行漏洞

  • 时间:3周前
  • 浏览:100次
近日,阿里云应急响应中心监测到fastjson官方git披露fastjson存在最新反序列化远程代码执行漏洞攻击Gadgets,利用该最新的Gadgets,攻击者可远程执行服务器任意命令,继而控制服务器权限,风险极大。官方已发布最新版本1.2.61修复该漏洞,请使用到fastjson的用户尽快升级至安全版本。
漏洞详情:https://help.aliyun.com/noticelist/articleid/1060056174.html
CVE
披露时间
2019年9月20日 10:00:50
CVSS
10
危险等级
严重
漏洞特征
远程代码执行
详情
fastjson采用黑名单的方法来防御反序列化漏洞,导致当黑客不断发掘新的可攻击的反序列化Gadgets类时,则可轻松绕过黑名单防御机制,反序列化漏洞就会再次出现。阿里云应急响应中心提醒fastjson用户尽快采取安全措施阻止漏洞攻击。 影响版本 fastjson < 1.2.61 安全版本 fastjson >= 1.2.61 fastjson自1.2.5X版本以上默认关闭autotype,默认配置不受漏洞影响
修复建议

升级至安全版本,参考下载链接:http://repo1.maven.org/maven2/com/alibaba/fastjson/

留言反馈

Copyright ©刘相涛 powered by zblog 加入我们| 网站地图| 业务合作
歌曲 - 歌手
0:00